World Intellectual Property Organization

PCT-SAFE Editor Quick Reference Guide v1.98

Documentation Overview

The PCT-SAFE Editor (the "PSE") is supplemented with several training and documentation resources.  These include an on-line help user manual, the tip-of-the-day, a training guide, sample documents and files, this quick reference guide, and other topical materials.  In the future, additional materials will be made available.

Tips and Tricks

Importing Content from Microsoft DOC

Getting high-quality images from DOC

  • Saving high-quality images from DOC: When saving documents to HTML, DOC automatically saves images (equation editor objects, chemical structure drawings, images, etc.) at "screen resolution" – about 100dpi (dots per inch). This is good for reading HTML on-screen, but a higher resolution looks better for printed documents.   To increase the quality of images from DOC, simply increase the output resolution: in DOC, choose Tools > Options; DOC will open the Options dialog box next, click the General tab, and click the Web Options button; DOC will open the Web Options dialog box; finally, click the Pictures tab and click inside the Pixels per inch field; type 400 into the Pixels per inch field and close the dialog boxes by clicking the OK buttons.   Now when you save this document to HTML, the images will all be at 400dpi – the highest resolution allowed by the Annex F standard. (Note that DOC may only keep this setting for the current document; to make the change permanent, you may have to open the "normal.dot" DOC template and save the change there.)
  • Scaling high-quality images to the right size:  If you have set DOC to save images at 400 dpi (4 times normal screen resolution), you must tell the PSE to display them at one fourth size.  This is easy:   when the PSE shows the Invalid Content dialog box, just type 25% into the Scale field and click the Convert All button.   The PSE will automatically scale the display size of the images down to the correct size – but the images will still be very high quality!
  • Setting PSE image conversion defaults:  You can set the PSE to default to 25% Scale or any other image conversion setting.   Just choose Tools > Conversion Options from the PSE main menu.

Saving "filtered" HTML

  • To make importing existing application documents easier, the PSE is designed to import any HTML (the language that web pages are written in, that most word processors can create).  However some software applications, including Microsoft DOC, create "non-standard" HTML.  In DOC 2002 and higher, you can avoid most of the "non-standard" HTML by choosing "Web Page, Filtered" in the Save as type box when you Save As HTML.    DOC 2000 also has this feature, but it must be downloaded from Microsoft (at no cost) and installed separately as an add-in.  DOC 97 does not have this feature, but it creates fairly simple HTML so you should not have any problems with its HTML.

Setting inline images to display "inline"

  • Many chemical structures and equations are meant to be displayed on a separate line, so these so-called "inline" images imported from DOC are automatically shown on their own line.  However, you can set them to display "inline" by viewing the Attribute Inspector (from the PSE main menu choose View > Attribute Inspector) and selecting "yes" in the inline field.

Drawings Section Tips

Figures vs. Drawings Pages – Which to Use?

  • Figures should be used when you have a separate image file for each figure or drawing.  The system automatically numbers each figure sequentially.  (Note:  a custom figure number feature is planned for a future version of the PSE.)   For example, if you have one single TIFF file for each drawing, and they are numbered sequentially (1, 2, 3…) then you should insert them as Figures.
  • Drawings Pages should be used when you have multiple figures or drawings in each image file, or when you have special figure numbering.   The system does not add any numbers or any other data – it just displays the pages you insert as they are.   For example, if you have a multi-page TIFF or PDF file that contains all your drawings already laid out on the pages, you should use Drawings Pages.  Or, even if you have a separate image file for each drawing, but you use numbers like 2A, 2B, 2C, then you should make sure the numbers are in the image file, and use Drawings Pages.
  • You may have either Figures or Drawings Pages, but not both.   This rule is stipulated by the Annex F standard DTD.
  • If your selected RO doesn’t accept PDF files (i.e. USPTO) the system will automatically convert the PDF to multiple TIFF files (one per page).   By default, the system will prompt you before performing the conversion.
  • The system will automatically convert any file that is non-Annex F compliant (i.e. GIF, multi-page TIFF), and prompt you before-hand by default.

Conversion Not Compatible with Acrobat 6 Files

  • The PDF files created by Acrobat version 6 have a new file format that is different from all previous PDF files.  These files are not compatible with the PSE – if you try to insert one of these files into a Drawings section with an RO that doesn’t accept PDF files, the PSE will try—and fail—to convert the file.   Furthermore, the PSE will display an error message and leave the conversion status message on-screen.   You should save your document and re-start the PSE if this happens.
  • Fortunately, if you have been given a PDF file that was created by Acrobat version 6, you can convert the format if you have an earlier version of Acrobat.   Just open the PDF file in Acrobat and print to the PDFWriter or the Distiller from Acrobat version 5 or lower.  Acrobat will create a new PDF file that is compatible with the PSE.

Editing Tips

Claims

  • Claims that have multiple paragraphs (called "claim text" sections) can be "split" into two separate claims by pressing [Shift]+[Enter] while the cursor is on one of the claim text sections
  • A new claim can be inserted after the current claim by pressing [Ctrl]+[Enter] or by clicking the New Claim button or menu item
  • Claim text sections can be indented by pressing [Tab] or by clicking the Demote Claim button or menu item
  • Note that lists (bullet or numbered) are not allowed inside claim text, but you can always type multiple entries in separate claim text sections

Tables

  • By default, table grid lines are visible on-screen, but are not printed (similar to a spreadsheet).  To enable printing of table lines, open the Table Properties dialog and set the Frame box to "all."  Individual row, column and cell borders can be controlled by setting the Column and Row Separator boxes to "1" (lines on) or "0" (lines off).
  • Header rows can be repeated on long tables that span multiple pages by selecting the desired rows, opening the Table Properties dialog, and setting the Row type box to "Header."
  • Many types of row/column/cell operations are available on the Table menu such as insert/delete, merge, and split.

Tags On view

  • The Tags On view, recommended for intermediate-level users or those with a knowledge of XML, is a combination of the Normal view with XML tag markers shown in-place.  This view can be very helpful to identify structural elements, detailed formatting options, or just to see where each tag starts and ends.  It also allows you to "collapse" and "expand" any tag or section of the document, by clicking on the plus/minus sign on each tag.

Templates

  • The PSE installs with two general-purpose templates, but it’s easier than you might think to create your own!  Just save any document into the following folder:  C:\Program Files\PCT-SAFE Editor\Template\WIPO.  That document can now become the starting point for any new document when you choose File, New.
  • You can create your own template folder, such as C:\Program Files\PCT-SAFE Editor\Template\My Templates.  Any template files you save there will show up on a separate "tab" on the File, New dialog.
  • You can set a default template that opens automatically when the New button is clicked.  Open the Tools, Options dialog, click the File tab and then click the Choose button next to the Default template box.

Keyboard shortcuts

Many shortcut keys for menu commands are indicated on their respective menus.  All menus, menu items, and dialog box controls are accessible by pressing the [Alt] key and the underlined letter (also called an "access key") associated with that control. The PCT-SAFE Editor also supports shortcut keys for window and dialog box navigation.

In addition to these access keys for calling menu commands and dialog box controls, there are a variety of keyboard shortcuts available that perform other functions. These keyboard shortcuts fall into several categories.  Each category of keyboard shortcut commands is listed below, with a table containing all shortcut keys.

File commands

These shortcut keys give you access to file manipulation commands.

Action

Shortcut

Create a new document from the default template (you can select a default template using Tools, Options, File tab)

[Ctrl]+[N]

Create a new document by choosing a template

[Ctrl]+[T]

Open a document

[Ctrl]+[O]

Open a document from the recently-opened list

[Alt]+[F]+number key

Close a document

[Ctrl]+[W] OR [Ctrl]+[F4]

Save a document

[Ctrl]+[S]

Save all documents

[Ctrl]+[Q]

Quit PCT-SAFE

[Alt]+[F4]

Display online help

[F1]

 

Editing commands

These shortcut keys give you access to common editing operations.

Action

Shortcut

Find and Replace

[Ctrl]+[F]

Find Next Forwards

[F3]

Find Next Backwards

[Shift]+[F3]

Find Selection Forwards

[Ctrl]+[F3]

Find Selection Backwards

[Ctrl]+[Shift]+[F3]

Undo an action (some actions may require selecting Undo multiple times)

[Ctrl]+[Z] OR [Alt]+[Backspace]

Redo an action

[Ctrl]+[Y]

Cancel an action

[Esc]

Spell checking

[F7]

Thesaurus

[Shift]+[F7]

Validate Document

[F9]

Select all

[Ctrl]+[A]

 

Switching between views and display modes

These shortcut keys switch between PCT-SAFE Editor's four editing views, and display invisible table grids.

Action

Shortcut

Toggle between Normal and Tags On views

[Ctrl]+Space bar

Switch to Plain Text view

[Ctrl]+[Shift]+[H]

Switch to Tags On view

[Ctrl]+[Shift]+[O]

Switch to Normal view

[Ctrl]+[Shift]+[W]

Switch to Print Preview

[Ctrl]+[Shift]+[V]

Hide/show table grid outlines (if no grid selected)

[Ctrl]+[Shift]+[Q]

Open or close the Attribute Inspector style='font-weight: (advanced users)

[Shift]+[F6]

Open and place active cursor in the Attribute Inspector style='font-weight: (advanced users)

[F6]

Open or switch Insert Element Pane to "Change element" mode style='font-weight:(advanced users)

[Ctrl]+[Shift]+[L]

Open or switch Insert Element Pane to "Insert element" mode style='font-weight:(advanced users)

[Ctrl]+[Shift]+[I]

 

Inserting, deleting, and moving text and markup

These shortcut keys enable you to perform common editing operations on text and markup.

Action

Shortcut

Delete one character to the left. If you are deleting from the first position in a tag, the first character in the tag to the left is deleted. Any empty tags in between the cursor and the text to be deleted is deleted as well.

[Backspace]

Delete one character to the right. If you are deleting from the last position in a tag, the first character in the tag to the right is deleted. Any empty tags in between the cursor and the text to be deleted is deleted as well.

[Delete]

Cut selection (copy to clipboard)

[Ctrl]+[X] OR [Shift]+[Delete]

Delete selection (do not copy to clipboard)

[Delete]

Copy selection

[Ctrl]+[C] OR [Ctrl]+[Insert]

Paste from clipboard

[Ctrl]+[V] OR [Shift]+[Insert]

Insert special character

[Ctrl]+[Shift]+[E]

Split element (where allowed by the DTD)

[Enter] OR [Ctrl]+[Shift]+[P]

Join to preceding element (where allowed by the DTD)

[Backspace] (at beginning of element) OR [Ctrl]+[Shift]+[J]

Join to following element (where allowed by the DTD)

[Delete] (at end of element)

Remove markup

[Ctrl]+[Shift]+[D]

Select element

[Ctrl]+[Shift]+[T]

Insert a comment

[F8]

 

List and Claims formatting

These shortcut keys perform list formatting.

Action

Shortcut

Demote selected list items to sub-list, >or when in the Claims section, demote the current claim text to be indented one level

[Tab]

Promote selected list items out of list, >or when in the Claims section, promote the current claim text to be out-dented one level

[Shift]+[Tab]

When in the Claims section, insert a new claim

[Ctrl]+[Enter]

When in a claim with multiple paragraphs ("claim text" sections), split into two separate claims

[Shift]+[Enter]

 

Moving around in a document

These shortcuts move the insertion point in the document window. See the next section for shortcuts for moving around in tables.

Action

Shortcut

Scroll to insertion point or selection

[F4]

One character to the left

Left arrow

One character to the right

Right arrow

One word to the left

[Ctrl]+Left arrow

One word to the right

[Ctrl]+Right arrow

Up one line

Up arrow

Down one line

Down arrow

To the end of a line

[End]

To the beginning of a line

[Home]

Up one screen (scrolling)

[Page Up]

Down one screen (scrolling)

[Page Down]

To the end of a document

[Ctrl]+[End]

To the beginning of a document

[Ctrl]+[Home]

 

Moving around in tables

These shortcuts move the insertion point in tables. See the previous section for shortcuts for moving around in the rest of the document window.

Action

Shortcut

Next cell in a row

Right arrow

Previous cell in a row

Left arrow

First cell in a row

[Alt]+[Home]

Last cell in a row

[Alt]+[End]

First cell in a column

[Alt]+[Page Up]

Last cell in a column

[Alt]+[Page Down]

Previous row

Up arrow

Next row

Down arrow

Outside the table

Click to right of the table

 

Making and extending selections

These shortcut keys enable you to make or extend selections (highlighted text or markup).

Action

Shortcut

One character to the right

[Shift]+Right arrow

One character to the left

[Shift]+Left arrow

To the end of a word

[Ctrl]+[Shift]+Right arrow

To the beginning of a word

[Ctrl]+[Shift]+Left arrow

To the end of a line

[Shift]+[End]

To the beginning of a line

[Shift]+[Home]

One line down

[Shift]+Down arrow

One line up

[Shift]+Up arrow

To the beginning of a document

[Ctrl]+[Shift]+[Home]

Select the current element

[Ctrl]+[Shift]+[T]

Select the entire document

[Ctrl]+[A]

 

Choosing menu items

These shortcuts enable you to choose commands from the menus.

Action

Shortcut

Show the shortcut (right mouse) menu

[Shift]+[F10]

Show the program icon menu (on the program title bar)

[Alt]+Space bar

Select the next or previous command on the displayed menu or sub-menu

Down arrow, Up arrow

Select the menu to the left or right; or, with a sub-menu visible, switch between the main menu and the sub-menu

Left arrow, Right arrow

Close the visible menu and sub-menu at the same time

[Alt]

Close the visible menu; or, with a sub-menu visible, close the sub-menu only

[Esc]

 

Moving between windows, documents, and dialog boxes

These shortcuts enable you to move between windows, dialog boxes, and documents.

Action

Shortcut

Switch to the next active program.

[Alt]+[Tab]

Switch to the previous active program.

[Alt]+[Shift]+[Tab]

Move the active cursor to the next document.

[Alt]+Right arrow OR [Ctrl]+[F6] OR [Ctrl]+[Tab]

Move the active cursor to the previous document.

[Alt]+Left arrow OR [Ctrl]+[Shift]+[F6] OR [Ctrl]+[Shift]+[Tab]

Show the Windows Start menu.

[Ctrl]+[Esc]

Close the active document window

[Ctrl]+[W]

 

Navigating in a dialog box

These shortcut keys enable you to select and use dialog box controls (controls are groups of one or more related objects, such as a push button, or a group of radio buttons).

Action

Shortcut

Switch to the next tab in a tabbed dialog box

[Ctrl]+[Tab] OR [Ctrl]+[Page Down]

Switch to the previous tab in a tabbed dialog box

[Ctrl]+[Shift]+[Tab] OR [Ctrl]+[Page Up]

Move to the next control

[Tab]

Move to the previous control

[Shift]+[Tab]

Move to control

[Alt]+underlined letter

Move between options in the selected drop-down list box

Arrow keys

Move between radio buttons in selected group

Arrow keys

Perform the action assigned to the selected button

Space bar OR [Enter]

Turn selected check box on or off

Space bar

Turn any check box on or off

[Alt]+underlined letter

Move to an option in a selected drop-down list box

First letter in option name

Open selected drop-down list box

[Alt]+Down arrow

Close selected drop-down list box

[Esc]

Perform the action assigned to the default button in the dialog box (if no other push button is selected)

[Enter]

Select a folder in a folder list

Arrow keys

Update the files visible in the Open or Save As dialog box

[F5]

Cancel the command and close the dialog box

[Esc]

Explore WIPO