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1. Introduction to the PCT-SAFE Editor

Welcome · Main Features · Document Conventions · Course Material

Welcome

Course participants will learn how to create a basic patent application body
using the PCT-SAFE Editor. Participants will learn how to prepare the
complete application body using basic PCT-SAFE Editor functionality such as
creating an application body, adding elements such as claim, lists, images
and tables, and printing and previewing application bodies. The material also
teaches participants how to import documents that were created using a word
processor.

This documentation is primarily for use by trainers to help train the end users
of the PCT-SAFE Editor.

Pre-requisite knowledge for the trainer assumes familiarity with word
processors. Basic knowledge of XML and/or HTML is desirable but not
required.

Pre-requisite knowledge for the participants assumes basic familiarity with
word processors.

Main features

The PCT-SAFE Editor is a software application to help prepare international
patent applications. The software has features similar to regular
word-processors such as the ability to create new documents, edit, save, print
and preview. The PCT-SAFE Editor creates structured patent applications
where the application body contains the necessary components such as
description, claims, abstract and drawings.

Document Conventions

This course uses several 'boxed-out' sections for certain conventions that we
will now explain. There are three types of information boxes, 'Hint', 'Note', and
'Exercise' , to provide additional information throughout the course. Exercise
boxes may sometimes contain an 'Answers' box.

'Hint' boxes show valuable tips and guidance information that can help you
use the PCT-SAFE Editor more effectively.
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Hint:
Common short-cut keys can be used in PCT-SAFE Editor such as [Ctrl+B] for
Bold.

Aqua 'Exercise' boxes contain practice questions that ask you to perform
actual document editing. Most modules will have an exercise where you
practice what has been taught in that module. Follow exercises step-by-step.
If an exercise has specific questions, there will be an Answers box.

Exercise
This exercise demonstrates the validation procedure and how to troubleshoot
errors in your application body.

• Open up "validation.xml" from the "Training Materials" folder.
• Make a change to the application body such as adding a new paragraph.
• Click on 'File/Save' to save the application body. A validation error will be

displayed.
• Attempt to fix the application body until you can save without any

validation errors.

Answers
The "validation.xml" application body is missing a claims section.

Try adding a claim from the Insert menu to add a claim to the
application body.

Note boxes provide additional information.

Note:
To add special characters to your application-body, click on the 'Insert' menu
then select 'Symbols.' A toolbar palette will open containing a selection of
accepted special characters.
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Course Material

The materials for this course are comprised of this Training document and the
following exercise files inside the Training Materials zip file or folder.

The Training Materials folder should contain the following files:

• abstract.htm
• chemistry sample.jpg
• claims.htm
• description.htm
• dimage1.tif
• dimage2.tif
• dimage3.tif
• dimage4.tif
• drawing sample.jpg
• drawings.htm
• elongase gene sample.xml
• image001.jpg
• image002.jpg
• math sample.jpg
• transmyocardial implant application.xml
• transmyocardial implant application.doc

Course participants will need to use a computer that has PCT-SAFE Editor
and Microsoft Word installed.
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2. Working with the Application Body

Creating a New Application Body · Saving and Closing an Application
Body · Document Views

Creating a New Application Body

Authors have two ways of creating an application body in the PCT-SAFE
Editor. This module will explain how to create a new application body by
opening up a default template. The next module will cover the second method
of creating a new application body by importing existing HTML files.

To create a new application body within the PCT-SAFE Editor, click on
'File/New'. Two basic templates are provided. These templates are used to
create new application bodies in the PCT-SAFE Editor:

• New Application Body
• New Minimal Application Body

Unlike most regular word-processors, a brand new application body is not
completely blank. Whenever a new application body is opened, there will be
some existing structural elements. The two types of templates both content
and have a set structure. For now, do not focus on the structure of the
application body. Application body structure will be discussed in a later
module.

Exercise
Follow these steps to create a new application body:

• Select 'File/New' - the 'New' dialog will appear, allowing you to choose
one of two templates.

• Select the "New Minimal Application Body" template.
• Add some text to the 'Invention Title' element
• Press 'F9' or select 'Tools/Validate Document'.
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Note:
The validation tool checks whether the application body has the correct patent
application structure. Validation will be discussed further in a later chapter.

After validation, the editor automatically adds additional information about the
application body in faint gray text at the the top of to the application body. The
new information, or metadata, includes the name and version of the XML
document type definition file, language and receiving Office settings.

Saving and Closing the Application Body

Saving and closing application bodies in the PCT-SAFE Editor should be a
easy task for most authors. Like many word processing tools, authors can
take advantage of standard "Save", "Save As" and "Close" toolbar items and
buttons. There are entries on the 'File' menu for these functions as well as
standard 'Save' and 'Save All' toolbar buttons on the main toolbar.

When closing an unsaved file, authors will be prompted to save the
application body.

Exercise
We will save the new application body created in the previous exercise:

• Select 'File/Save' - as this is a new application body, we are shown the
'Save As' dialog and prompted for a save location .

• Navigate to the 'Training Materials' folder, give the application body a
filename and click 'Save'.

The new application body is now saved.

One difference in behaviour is that PCT-SAFE Editor will check that the
application body structure conforms to the patent application structure before
saving. If the application body is not correctly structured, the author is given a
warning. During normal editing, the Save process should be identical to
regular word processors. More information on the application body structure is
offered in module 3.

Document Views

There are four views available to the author in the PCT-SAFE Editor. The
views are "Normal", "Tags On", "Page Preview" and "Plain Text." Change the
current view by clicking on the View Mode button at the bottom of the
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document window.

The "Plain Text" view is recommended for advanced users only and will be
covered in Module 16.

'Normal' view

This is the standard 'word-processor' view of the application body. Normal
view lets you concentrate on the content of your patent application. Most new
users will prefer to edit their application body in Normal view since the XML
tags are hidden from sight.

This diagram shows a typical application body in the 'Normal' view.
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Note:
The Structure View pane is displayed (by default) to the left of the document
window. It can be viewed independently of the application body using the
slider on the right hand side and can be used to edit text, and insert, cut,
paste, copy, and drag-and-drop elements.

The Structure View allows for convenient manipulation of larger application
bodies as by clicking on the (plus) or (minus) buttons to the left of each

element, the different levels can be opened and closed for easy navigation
through the application body.

In the structure view, you can edit text, and insert, cut, paste, copy, and
drag-and-drop elements.

To display or hide the structure view, click 'Tools/Options'. Click the View tab
then click 'Show Structure View.' Alternatively, drag the divider between the
structure view and the document view to close the structure view.

'Tags On' view

This view displays the application body in XML format where element tags are
visible. Tags On view as the name suggests displays the element names, or
tag names, for the document. This view allows for precise editing of structural
elements.

Hint:
Users should not worry about having to understand the XML tags at this stage
in the course material. These are simply tags that describe the content. For
example, the XML tags around the title of this invention are called
"invention-title."

Here is the same application body as shown above in Tags On view. Notice
that the paragraph is surrounded by a "p" tag. Surrounding the content by tags
will look familiar to users who have seen HTML. Tags On view is a valuable
view for intermediate and advanced users who want to see the XML tags
while editing their application body.
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Hint:
New users should start off working in 'Normal' view. As you become more
comfortable with the PCT-SAFE Editor, switch to the 'Tags On' view for more
advanced application body editing.

'Page Preview' view

Selecting the 'Page Preview' button will preview the application body in
Portable Document Format (PDF) format using Adobe Acrobat.

This is the official rendering of the application body, and will be identical to
the application body rendered at the receiving Office.
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3. PCT-SAFE Application Body Structure

Basic Application Body Structure: Description, Claims, Abstract and
Drawings

Application Body Structure

All patent application bodies created with the PCT-SAFE Editor will have the
same basic structure. The application body is comprised of four major
elements:

• Description
• Claims
• Abstract
• Drawing

Every application body must contain a description and claims element. The
application body may also contain abstract and drawing elements. The
elements must be arranged in the following order: description, claims, abstract
and drawings. All new application bodies created with the PCT-SAFE Editor
will already contain these basic elements. It is important for patent application
authors to be familiar with these different elements.

Description

The description element must disclose the invention in a clear and complete
manner. The description section starts off with "invention-title" element. This is
the appropriate place to type the title of the invention. There are many other
elements available in the description section such as:

• Technical-field
• Background-art
• Disclosure
• Description-of-drawings
• Best-mode
• Mode-for-invention
• Industrial-applicability
• Sequence-list-text

The main difference between the description element and the other parts of
the application body such as the claims or abstract is the large number of
available elements which can be used in the description. Formatting such as
bold, italic and underline is available, lists, tables and many types of
patent-application specific elements such as "disclosure" or
"industrial-applicability" elements are available to patent application authors.
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Exercise
• Select 'File/Open'
• Navigate to the file "elongase gene sample.xml" in the 'Training Materials'

folder.
• Using the 'Insert/Description/xxx' menu, experiment with adding more of

the description structures listed above to the open application body.

Claims

Each application body will have a claims section. Both the description and
claims sections are required for all application bodies.

There is one claims section for the entire application body.

Within the claims section, you can create one or more claim elements.

Each claim element can contain one or more claim-text elements. A claim-text
element is similar to a paragraph.
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Exercise
Add new claims to the application body.

• Using the current application body, "elongase gene sample.xml," and the
'Insert/Claim' menu, add some new claims.

Abstract

Following the description and claims elements, a PCT-SAFE application body
may contain an abstract. This abstract must consist of a summary of the
disclosures contained in the description, claims and drawings elements. The
abstract should be concise.

Unlike the description and claims elements, the abstract is not always
required.

Authors can create one of two types of elements in an abstract:

• Paragraphs
• Problem and Solution

Exercise
The Abstract element can contain either paragraphs or problem/solution
elements. This exercise will demonstrate how the PCT-SAFE Editor enforces
structured editing.

• To add an abstract and a paragraph inside that abstract, select
'Insert/Abstract/Paragraphs.'

• Now attempt to add a Problem/Solution pair to the abstract. Select
'Insert/Abstract/Problem-Solution.'

Hint:
Remember that an Abstract can contain either paragraphs or
problem/solutions but not both.

Drawings

A drawings section is not required for each applicatio body as far as the
PCT-SAFE Editor is concerned. However, sometimes drawings are necessary
for the understanding of the invention. The PCT-SAFE Editor supports the use
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of TIFF and JPEG graphics within the drawings section.

The Drawings section has very simple rules. A patent application author is
allowed to insert any number of images into this element.
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4. Importing Documents from HTML or Word

Importing HTML · Using the HTML Import Tool · Importing
Description, Claims or Abstract · Copy and Paste from Word

Importing HTML

HTML files which have been exported by other applications can be imported
into the PCT-SAFE Editor. HTML files can be imported as a new application
body, or imported as a description, claims or abstract section into an existing
application body. This module will focus on importing HTML files as a new
application body.

Exercise
Most word processors have the ability to save files as HTML. To prepare
non-HTML documents for import to PCT-SAFE Editor, use your word
processor to export the files to HTML format.

• Using Windows Explorer, ,navigate to the Training Materials folder.
• Open the file called "transmyocardial implant application.doc" in Word.
• Within Word, select 'File/Save as html'.
• Click 'Save' to save the file with an *.htm file extension in the same folder

as the "transmyocardial implant application.doc" file.

This document is now ready to be imported into the PCT-SAFE Editor.

Importing new documents into the PCT-SAFE Editor is a two-step process.
The first step will be to select the HTML file which will be brought into the
document window. The second step is to use the HTML Import tool to
separate the imported content into description, claims and abstract elements.

To import a new Patent Application document from HTML:

• From the Tools menu select Import HTML then Application Document.
• Browse and select an HTML file from the Select HTML File dialog box

and click Open.

A new document will open containing the imported content. Notice that the
HTML Import tab has been opened and is displayed next to the document.
The newly imported content has a gray background. The current document
does not contain the required sections such as description and claims, we will
be adding these sections with the HTML Import tool.
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Once all of the content has been fully imported into the application body,
clicking the "End Import" area in the HTML Import pane will close the pane
and delete the grey imported content section in the document.

Exercise
• In the PCT-SAFE Editor, select 'Tools/Import HTML/Application

Document'
• Navigate to the file 'transmyocardial implant application.htm' in the

'Training Materials' folder and click 'Open'.
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Using the HTML Import Tool

The imported content needs to be split up into the following application body
structure: description, claims, abstract and drawings (optional). The HTML
Import tool is used to identify the Description, Claims, Abstract and Drawings
sections.

To block out a section, use the HTML Import tool to add Section Start and
End markers. These markers are small blue diamonds.

• Place the cursor at the start of the content imported into PCT-SAFE
Editor. The cursor should be inside the grey area.

• In the HTML Import tab, click on Insert Section Start.
• Scroll down the document until you reach the end of the content that

belongs in the Description section. Place the cursor where the description
section should end.

• In the HTML Import pane, click on Insert Section End.
• In the HTML Import pane, click on Import Marked Content.
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• An 'Import Selection' dialog box will appear. Click on 'Yes' to confirm the
Import.

• The Select Import Section dialog will be displayed with option types for
'Description', 'Claims', 'Abstract' and 'Drawings.' Choose 'Description' in
the Select Import Section dialog box.

• Click on OK.
• Repeat steps to import each of the following elements: Claims, Abstract

and Drawings (if necessary).
• When all the content has been fully imported, click on End Import in the

HTML Import pane.

The import must be done in the following order: Description, Claims, Abstract
and Drawings (if necessary).

The resulting application body should have all the major elements such as
Description, Claims and Abstract. The HTML Import tab will be closed. Any
content that was not identified and imported into the application body is
deleted. The application body is now ready for further editing.
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Exercise
Identify and import the various sections of the application body.

Notice that there are differences in behaviour when importing into the
Description, Claims and Abstract sections. For instance, lists are not allowed
in the Claims section. All lists imported into the Claims section are
transformed to claim-text elements.

• By following the above HTML Import instructions step-by-step, identify
and import the Description section.

• Click on the "Move Cursor to Imported Content" button to bring the cursor
back to the imported content. Now, identify and import the Claims
section.

• Click on the "Move Cursor to Imported Content" button to bring the cursor
back to the imported content. Now, identify and import the Abstract
section.

• Select 'End Import' from the HTML Import.

Hint:
If you select the wrong content to import, click 'Clear existing start
and end markers' on the HTML import page.

Newly imported documents should be reviewed to make sure that they are
correctly structured. Pay particular attention to the claims section. The HTML
import process creates a single claim into the claims section. This claim and
its multiple claim-texts should be split into multiple claims.

Exercise
Split up the single claim into multiple claims.

• Scroll down to the claims section of the application body.
• Evaluate the content of each claim-text.
• If that claim-text should be split into a separate element, place the cursor

in the claim-text and press [Shift+Enter] .

Claims will be revisited later in the course in module 9.

18



Importing Description, Claims or Abstract

The previous example showed how to create a brand new application body by
importing a single HTML file into the PCT-SAFE Editor. There is a second
way to import content by importing HTML files that only contain content
targeted to one of the specific elements such as Description, Claims or
Abstract.

Individual description, claims or abstract sections can be created by importing
HTML files into an existing application body. For example, an author might
want to create the Description section in HTML and import it into the
PCT-SAFE Editor.

To import an HTML page into a section:

• From the Tools menu select Import HTML then choose one of the
following sections:

• Description Section
• Abstract Section
• Claims Section

• Browse and select an HTML file from the Select HTML File dialog box
and click 'Open'. The content is inserted into the current application body
at the end of the selected section.
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Exercise
In this exercise we will import some existing content for our description
section.

• Open up a new application body template by selecting 'File/New/New
Minimal Application Body'.

• Select 'Tools/Import HTML/Description Section'.
• Navigate to the file 'description.htm' in the 'Training Materials' folder and

click 'Open'.

Note:
The new description area only contains paragraphs. In the next few
steps, we will add some more XML elements to the description
section.

• Using the 'Insert/Description' menu, insert a new Invention Title. Drag and
drop the following text "STABILIZED TRANSMYOCARDIAL IMPLANT"
from the newly imported content into the Invention-Title.

• Using the 'Insert/Description' menu, insert a new Technical Field into the
Description area. Drag and drop paragraphs from the newly imported
content into the Technical Field element.

Copy and Paste from Word

Content can be inserted into a application body by copying and pasting it from
other word processor applications such as Microsoft Word. Copying and
pasting will also work from most text editors using the same steps.

To import content by copying and pasting from Word:

• Place the cursor within a paragraph or claim-text element.
• Switch applications to Microsoft Word and select and copy the text you

want to import.
• Switch applications back to PCT-SAFE Editor and click Paste on the

Standard toolbar or press [Ctrl+V]. The content will appear in the
application body.

When a paste occurs, new elements might be created in order to keep the
XML markup valid. The original content from the clipboard will be preserved
but new or additional elements may be created.
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5. Adding New Elements to an Application Body

Insert Menu · Insert Toolbar

The Insert Menu

Authors should now be familiar with the description, claims and abstract
elements. Authors may wish to add even more elements to their application
body and should use the Insert menu for this purpose. The following elements
can be added to the application body through the Insert menu.

Notice that the Insert menu contains submenus. To add a specific element
inside the Description element, go to the Insert menu then select Description
then select the sub-element.

• 'Description' sub-menu

• 'Invention Title'
• 'Paragraphs'
• 'Technical Field'
• 'Background Art'
• 'Disclosure' sub-menu

• 'Problem-Solution'
• 'Paragraphs'
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• 'Description of Drawings'
• 'Best Mode'
• 'Mode for Invention'
• 'Industrial Applicability'
• 'Sequence List Text'

• 'Claim'
• 'Abstract' sub-menu

• 'Problem Solution'
• 'Paragraphs'

• 'Figure' sub-menu

• 'Drawing'
• 'Inline Image'
• 'Chemistry'
• 'Math'

• 'Heading'
• 'Definition List'
• 'Symbols'
• 'Line Break'

PCT-SAFE has a strict application body structure and this is reflected in the
submenus. The 'abstract' element can only contain paragraphs or
problem-solutions. The 'description' element can contain many more different
types of elements. Sometimes, an element may only contain one
sub-element.
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Exercise
In this exercise, we will practise adding elements to an existing application
body.

• Select 'File/Open'
• In the Open File dialog box, navigate to the file "transmyocardial implant

application.xml" in the 'Training Materials' folder and click 'Open'
• Move to the 'Tags On' view.

Note:
In Tags On view, the start and end tag for each element are visible.
In this view, it is easier to see how the elements are nested.

• Find the <p> paragraph element inside the <description> element and
click on the greyed text. Type on top of this text to add content to your
paragraph.

• Now insert a line break into your paragraph by selecting 'Insert/Line
Break'

• Using the Insert menu try to find and add the following elements to the
current application body:

• 'Best Mode'
• 'Disclosure' - Paragraphs
• 'Disclosure' - Problem-Solution

• Move your cursor around the application body and experiment with
adding different types of elements from the Insert menu.
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The Insert Toolbar

The Insert toolbar contains buttons that you can use to insert new elements in
your application body. This table shows the buttons that appear on the Insert
toolbar.

Button Name/Tooltip Menu command Description

Insert Drawing Insert > Figure >
Drawing

Insert Drawing

Insert Inline
Image

Insert > Figure >
Inline Image

Insert Inline
Image

Insert Chemistry Insert > Figure >
Chemistry

Inserts a
Chemistry figure

Insert Math Insert > Figure >
Math

Inserts a Math
figure

Heading Insert > Heading Inserts a
Heading Insert

Table Table > Insert
Table

Inserts a Table

Insert Definition
List

Insert > Definition
List

Inserts a
Definition List.
Definition Lists
contain paired
values of terms
and definitions.

Insert Break Insert > Line
Break

Inserts a Line
Break
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6. Working with Formatting and Lists

Bold, Italic and Underline styles · Adding Lists

Bold, Italic and Underline styles

The PCT-SAFE Editor allows you to style paragraph text with bold, underline,
italic, subscript and superscript styles.

Within a paragraph, table entry elements and other types of elements, the
formatting styles functions are available from the Formatting toolbar.

Bold Sample

Sample Italic

Underline Sample

Superscript Sample

Subscript
Sample

Formatting styles can also be applied with the Font properties dialog box
available through the 'Format/Font' menu.
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Exercise
• Using the 'Format/Font' menu item to open the font properties dialog, add

formatting to the current application body.

Hint:
When a font property check box is displayed in grey, it means that
some rather than all of the current selection is bold or italic.

It should now be apparent that the PCT-SAFE Editor behaves slightly
differently from regular word processors. This software application focuses on
the document's structure and tries to enforce structural rules. As a result,
these formatting styles may not be available in every type of element. In
general, you can use formatting styles in most areas inside the Description
element and within any paragraph element.

Adding Lists

Three types of lists are supported in the PCT-SAFE Editor. Numbered,
bulleted and definition lists.

To insert a new numbered or bulleted list:

• Place the cursor where you want to insert the list.
• Click Numbered List or Bulleted List on the Formatting

toolbar.
• A new list is created, containing a single list item.

If the contents of the list item are not surrounded by a sub-element such as a
paragraph, then pressing [Enter] in a list item inserts a new list item after the
current one. If the contents are surrounded by a sub-element, then you need
to press [Enter] twice to create a new list item.

Definition lists are structured lists made up of pairs of terms and definitions.
To insert a new definition list:

• Place the cursor where you want to insert the list.
• Click Definition List n the Insert toolbar.

• A new list is created, containing a pair of list items.
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7. Working with Images

Drawings, Inline Images, Math and Chemistry · Editing Image
Properties

Drawings, Inline Images, Math and Chemistry

The PCT-SAFE Editor allows you to include images within your application
body. The PCT-SAFE Editor supports the use of JPEG and TIFF images.
There are four basic types of images:

• Drawings
• Inline Images
• Math
• Chemistry

Drawings are images that are contained in the Drawings element at the end of
the application body. Inline images can be added throughout the application
body. Math and Chemistry figures can be added throughout the application
body but should only contain images related to Math or Chemistry figures or
equations.

Exercise
Add an Image to the Drawings section:

• Select 'Insert/Figure/Drawing'.
• Navigate to the "drawing sample.jpg" file in the 'Training Materials' folder.
• Click OK - this will insert the drawing into your application body.

Math and Chemistry formulas need to be prepared as JPEG or TIFFs in order
to be used in the PCT-SAFE Editor. To insert a Math or Chemistry figure,
select 'Insert/Figure' and then the appropriate menu item.
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Exercise
Add a math formula:

• Select 'Insert/Figure/Math'
•

• Navigate to the "math sample.jpg" file in the 'Training Materials' folder
• Click OK - this will insert the math formula into your application body

Add a chemistry formula:

• Select 'Insert/Figure/Chemistry'
• Navigate to the "chemistry sample.jpg" file in the 'Training Materials'

folder
• Click OK - this will insert the chemistry formula into your document
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Editing Image Properties

Every image has some associated properties including a description of the
image content, height and width and alternative text (textual description about
the image useful when images cannot be displayed).

To view or edit the image properties associated with an image:

• Place the cursor on the image.
• Right-click and select Image Properties.
• The Image Properties dialog is shown, make any required changes and

click on 'OK'

Hint:
Shaded image properties are not editable in the 'Image Properties' dialog.
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8. Working with Tables

Inserting Tables

Inserting Tables

The PCT-SAFE Editor allows you to insert tables within your application body.
The Table menu items offers standard Table operations such as the following:

• Insert Table
• Insert Caption
• Insert Rows or Columns
• Delete Row
• Delete Column
• Move Row Or Column
• Merge Cell
• Split Cell Into Columns
• Split Cell Into Rows
• Table Properties

The default size for new tables is 2 rows by 2 columns.

Exercise
• Select 'Table/Insert Table'
• Create a table with 5 rows and 4 columns.
• Select 'OK.'
• Click inside one of the table cells.
• Select 'Table/Insert Table Title' - the table title is added which you may

edit.
• Click inside one of the table cells. Try adding some text and formatting -

note that you can insert the same content within a table cell as you can
inside a paragraph, with the exception of line breaks and further tables.

• Select 'Table/Insert Rows or Columns' - this opens the insert rows and
columns dialog.

• Check that 'Row Below' is selected. Click 'OK' - this will add a row to your
table.
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9. Working with Claims

Importing and Splitting Claims · Promoting and Demoting Claim Text

Importing and Splitting Claims

The PCT-SAFE Editor allows you to import HTML sections directly into a
Claims element. This concept was introduced in an earlier module. When
claims are imported into the PCT-SAFE Editor application body, their structure
is modified from a list-based structure to a claim based structure. Authors
should review the imported claims and ensure that each claim has been
imported correctly and if necessary, split these claims. Claims may need to be
split.

To split a claim:

• Position the cursor inside the claim-text that needs to be split.
• If the claim-text needs to be split, click on [Enter]
• Click on [Shift+Enter] to split the claim.

Exercise
Import HTML content into our claims section.

• Open up a new application body.
• Select 'Tools/Import HTML/Claims Section'.
• Navigate and open 'claims.html' file in the 'Training Materials' folder.

Note:
Note that each paragraph of the HTML content is now a <claim-text>
and not a separate <claim>. Authors will have to determine where
each claim should be split.

• Select groups of claim-texts, or place the cursor in the claim-text and run
the Split Claim function, [Shift+Enter], to break up the claim into multiple
claims.

Promoting and Demoting Claim Text

Claim-text items can be promoted or demoted. Promoting or demoting is an
action similar to indenting or outdenting paragraphs. Claim text items are
nested inside one another to mimic indenting or outdenting.
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To promote a claim-text:

• Place the cursor inside the claim-text element.
• Click Promote Claim Text on the Formatting toolbar or press

[Shift+Tab].

To demote a claim-text:

• Place the cursor inside the claim-text element.
• Click Demote Claim Text on the Formatting toolbar or press [Tab].

Exercise
Practice promoting and demoting claim-text with the current application body.
How does promoting and demoting claim text affect the claim element's
structure?

32



10. PDF Print and Preview

PDF Page Preview · PDF Print

PDF Page Preview

PCT-SAFE Editor application bodies are formatted in XML. The use of XML is
powerful because it allows the application body to be transformed from XML
to different formats. In this software, the XML application body can be
previewed in PDF format. There is a built-in Page Preview window which uses
Acrobat Reader to display the PDF file. From this Page Preview window,
authors may use the various Acrobat functions such as Print to PDF, Save As,
Zoom and Rotate.

To see a PDF Preview of the current application body:

• Click on the Page Preview button at the bottom of the

document window.

A DOS window will appear briefly while the application body is being
transformed.

Exercise
PCT-SAFE Editor will allow you to preview the application body in Adobe
Acrobat within the Page Preview pane.

• Select 'View/Page Preview'
• Use Acrobat's built-in functions such as "Save A Copy" to save the PDF

onto the local machine.
• If the local machine has access to a printer, print the application body

using the Acrobat print button.
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PDF Print

To quick print from PCT-SAFE Editor:

• On the File menu, click Print.
• A PDF document will be generated and sent to the default printer.

Exercise
XML application bodies can be transformed into different output types using
XML style sheet transformations (XSLT). Think of XML application bodies as
raw material. Raw material can be processed to create many different types of
products. An XML application body can be transformed to many different
types of output types.

When clicking on Page Preview, the application body is transformed using
XSLT into the PDF format. The resulting PDF file is then displayed in the
Page Preview pane.

Name other types of output that could be created with the same application
body.

Answers
Using different types of transformations, the same patent application
could be delivered in HTML format, translated to Wireless Markup
Language (WML) for use in mobile phones, transformed to Word
format, plain text or reorganized to publish only certain parts of the
application such as the abstract.
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11. Using Editing Tools

Spell Check · Thesaurus

Spell Check

PCT-SAFE Editor features spell-checking capabilities. Spell checking is
available from the 'Tools' menu.

Exercise
We will now spell check our current application body using the PCT-SAFE
spell checker:

• Select 'Tools/Spelling'
• Click 'Next' 'Replace' or 'Ignore' for all the words the spell checker

identifies as potentially incorrect.
• Click 'Cancel' to close the dialog once you are finished.

Thesaurus

To run the Thesaurus tool:

• Go to 'Tools/Thesaurus'

The Thesaurus dialog will open.

Exercise
Replace some of the words in your application body with alternatives provided
by the thesaurus:

• Select a word
• Select 'Tools/Thesaurus' to open the thesaurus dialog.
• Click on a replacement word from the selection in the text box.
• Click 'Replace' to replace the word in your document with the one

selected.
• Click 'Cancel' to close the dialog.
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Note:
It should be kept in mind that the person using the PCT-SAFE Editor may not
be the author and would probably not be in a position to make editorial
changes such as changing words using the Thesaurus tool.
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12. Advanced Topics: Introduction to XML

XML Basics · What are Elements · What are Attributes

XML Basics

Extensible markup language or 'XML' to give it the appropriate abbreviation, is
the underlying format for the PCT-SAFE Editor. XML is a text based 'mark-up'
format, designed to be both human and machine readable.

XML may seem familiar to those who are familiar with HTML (Hypertext
Markup Language). HTML is a structured markup language that is used to
create documents that can be viewed in web browsers. The PCT-SAFE Editor
is an XML application that creates documents that are structured in the
correct format expected for patent applications.

Every application body that is created with PCT-SAFE Editor will conform to
the set document structure that has been described throughout this course. In
XML jargon, the document structure is known as the Document Type
Definition (DTD). All documents must comply with this structure. Documents
that comply are said to be "valid" documents.

What are Elements?

Throughout this course, we have referred to "elements." What is an element?
It is the proper name for a set of XML tags and the content within them.
Elements normally have start and end tags such as claim-text:
<claim-text>your content goes here</claim-text>.

As you have learned in this course, different elements have different rules
about what can be contained inside them. For example, "claims" can only
contain "claim" elements which can only contain "claim-text."

Fundamental to XML is the concept of having document elements describe
their content. The element names are meaningful in XML:

By using XML elements, a person can look at the document and know that
that <p> is the paragraph and that <heading> is a title of some sort - and we
have even identified a keyword. This sort of tagging allows us to tell two
pieces of text apart. This is also useful for computer programs which can be
instructed to read the tags and treat the pieces of text in different ways.

A single XML document is made up of many "hierarchical" elements. All the
elements exist within other elements, which are contained within one "root"
element. The "root" element for PCT-SAFE Editor is the "application-body"
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element.

XML documents are often described as "trees" starting with the "root"
element, "application-body", which is the "ancestor" of all the elements below
it.

The graphic above shows the "tree" shape of XML documents. It has been
highlighted in blue.

What are Attributes?

The term "attribute" might be a new concept. During this course, we
mentioned "elements" frequently. Attributes are properties of elements.
Attributes are values that provide additional information about a particular
element.

The top-level element for a document is called the "application-body" element.
It contains some additional information about the document such as the
language, receiving Office and the DTD version. This information is displayed
in light grey text at the top of every application body. The XML tag would look
like: <application-body lang="EN" country="US">...</application-body>

In the case of the application-body element, the extra attributes add extra
information about this particular application body to the XML. Here we see
that the default language for the application body is English and that the
receiving Office, or country, is the United States.

Different elements will have their own unique attributes. Many elements will
have at least one "id" attribute which can be used to identify that particular
piece of text. Some elements have no attributes such as "claim-text"
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elements.

Under normal editing, authors should not have to add attributes to the XML.
This is done automatically by the PSE.
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13. Advanced Topics: The Element List

The Element List

The Element List

The various options on the 'Insert' menu, together with other buttons and
functions within the PCT-SAFE Editor are used to insert elements into the
application body. There is a second way to add elements into your application
body through a dialog called the Element List. The Element List is appropriate
for more advanced users.

The Element List can be toggled to show or hide using the 'View' menu.

The Element List displays a list of the elements that can be inserting into the
application body. The Element List is context-sensitive which means that only
the elements which can be inserted at the current cursor position are shown.
For example, in the image below, only two elements can be inserted at the
current cursor position: heading and paragraph.

To insert an element:

• Double-click on the element name

Element names displayed in bold are "required" elements at that cursor
position.
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Exercise
Use the Element List to insert the following types of Elements into a PSE
application body:

• heading
• disclosure
• technical-field
• claim-text
• i ( italics )

Hint:
Move into Tags On view and click around various parts of the
document. Notice that the Element List changes depending on your
position in the document.
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14. Advanced Topics: The Attribute Inspector

The Attribute Inspector

The Attribute Inspector

When creating and editing application bodies with the PCT-SAFE Editor,
attribute values for elements are automatically added to the XML. Users will
not normally have to use the Attribute Inspector to add attribute values to
elements.

The Attribute Inspector can be toggled to show or hide using the 'View' menu.

The Attribute Inspector displays the current element followed by a list of the
attributes that can be set for that element. The attribute names are displayed
on the left, the attribute values are entered by the author on the right.

To view an element's attributes:

• Make the Attribute Inspector visible by selecting 'View/Attribute Inspector'
• Click inside or on the element whose attributes you wish to view.

Here we see that the paragraph element has two attributes:

Attribute names displayed in bold within the Attribute Inspector are required
and must hold a non-empty string value. Attribute values can contain text or
maybe have drop-down lists.
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Note:
Avoid manually changing attribute values. Many attributes are set
automatically by the Editor.

In most cases, editing attributes manually is not necessary.

Exercise
Open the sample file "transmycardial implant application.xml" from the
Training Materials folder.

Use the Attribute Inspector to view the attributes of the following elements:

• application-body
• description
• technical-field
• claim-text
• img

Hint:
Use 'Tags On' view to see the element names.
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15. Advanced Topics: Validation

XML and Validation · Validating the Application Body

XML and Validation

In the XML vocabulary, the term "validation" refers to the process of
evaluating a document to ensure that it complies with a specific document
structure. This document structure is defined by a set of rules called the
Document Type Definition (DTD). The DTD will dictate what a "valid"
document should contain. For instance, the PCT-SAFE Editor uses a DTD
called "application-body" which dictates that each application-body document
must have a description, a claims section and optionally can have abstract
and/or drawing elements. By now, authors should be familiar with this basic
application body structure.

The PCT-SAFE editor will check, or "validate", each application body against
this set of rules to ensure that it meets the requirements set out by WIPO. If
the application body structure matches the rules described in the DTD, we call
that application body "valid".

During editing, the PCT-SAFE Editor tries to keep each application body valid.
For instance, elements can only be inserted in the locations permitted by the
DTD. When deleting elements, the PCT-SAFE Editor will try to keep the
application body structure valid even if that means that the deletion may not
occur.
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Exercise
This exercise demonstrates how an application body is prevented from
becoming invalid during an editing session.

• Open up a new application body using the "New Minimal Application
Body" template.

• Select 'Tags On' view.
• Click on the opening <description> tag to select the description element.

Make sure that you have selected both the contents and the actual
<description> tags. The <description> tag should now be highlighted.

• Press the "Delete" key on your keyboard.

What would you expect from a regular word processor? Why did the
PCT-SAFE Editor prevent you from making this deletion?

Answers
Most regular word processors do not enforce document structure.
They would allow the user to delete this element.

PCT-SAFE Editor would not delete the description element because
it is required. The PCT-SAFE Editor will prevent most actions that
invalidate your application body.

Validating the Application Body

Ensuring that the XML application body is valid is vital to the submission of
your patent application. Even though the PCT-SAFE Editor tries to prevent the
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creation of invalid XML, problems may still occur especially when authors use
advanced features such as the Element List, Attribute Inspector and Plain
Text view.

Hint:
During editing, periodically use the Validate Document function to ensure that
the current application body has no structural errors.

PCT-SAFE automatically validates application bodies before saving them.
The validation routine can also be run through the "Validate Document"
function on the Standard toolbar or by pressing the [F9] key.

When the application body is valid, the following dialog is shown:

When a document does not meet the DTD requirements, the Validation Log is
shown with the various errors. Clicking on an error message will move the
cursor to the problematic element.
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Exercise
This exercise will demonstrate how to use the to use the Validate Document
function to troubleshoot an invalid application body.

• Open up the sample "transmycardial implant application.xml" application
body in the Training Materials folder.

• Press 'F9' to validate your application body. The application body should
be valid.

• Ensure that the application body is in 'Tags On' view.
• Move down to the drawings element. Select and delete some of the "img"

tags.

Note:
The drawings element must contain figure elements. Each figure
element must contain exactly one img element which refers to the
actual graphic image file.

• Press 'F9' to validate your application body.
• Click on the top-most error message.
• Click on 'Go To' which moves the selection to the part of the application

body where the error occurred.
• Click on 'Close' to dismiss the dialog.
• By clicking around the document area and using the Element List to help,

find a way to make the application body valid again.
• Press 'F9' to validate your application body.

Answers
There are three different ways to make this application body valid
again such as:

• Using the 'Undo' toolbar button to undo the deletion
• Remove the figure element
• Add an img tag using the Element List. Notice that you would also

have to add in the attributes for the img manually using this method.
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16. Advanced Topics: Plain Text view

Editing in Plain Text view

Editing in Plain Text view

The three views, 'Normal', 'Tags On' and 'Page Preview' were introduced in an
early module, 'Plain Text' view, which displays the raw XML markup, is
intentionally introduced at the end of the course. The 'Plain Text' view is only
recommended for experienced XML authors.

To move to 'Plain Text' view go to the View menu then click on 'Plain Text'.
This view shows the raw XML application body which the PCT-SAFE Editor
has created. All of the XML tags are visible and an author can change any
and all tags.

That there are no editing constraints in this view. An author could make a
application body invalid by deleting required tags or by introducing any
number of common XML errors. However, if the application body is made
invalid in Plain Text view, the author will not be able to return to 'Tags On' or
'Normal' view until those errors have been fixed.
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Exercise
It is possible to invalidate your application body with potentially damaging
results. To demonstrate this, we will now deliberately make our application
body invalid.

• Create a new application body using the "New Application Body"
template.

• Save the application body as "MyPlainText.xml" on the local machine.
• Click on 'View/Plain Text' to get into the 'Plain Text' view. This is the raw

XML view of the application body - notice the color coding of the different
parts of the text.

• Select a group of XML tags such as the description tags.
• Delete this selection with the 'Delete' key.
• Press [F9] to validate your application body.
• Try to select the 'Normal' or 'Tags On' view.
• Try to make the application body valid in order to move to 'Normal' or

'Tags On' view.

Hint:
Authors familiar with XML can fix these types of problems manually,
otherwise select 'Edit/Undo' to undo the changes to the application
body.

The 'Plain Text' view is available for authors who know the rules of XML and
understand the DTD well enough to edit in raw XML. The general introduction
to XML given in this course is not a sufficient basis for raw XML authoring.
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